Rootsmagic upgradeIf you use RootsMagic to work with FamilySearch Family Tree, you must install a RootsMagic update (version 7.0.6.0) to continue working with it after July 30, 2015!

FamilySearch will be making changes to its own site on July 30, 2015. These changes require RootsMagic to change their own code a little, so RootsMagic users can stay fully compatible with FamilySearch Family Tree.

Here’s the scoop from a RootsMagic press release:

“If you are running RootsMagic 7…. If you haven’t already downloaded the update, look for the “Update Available” indicator in the lower right corner of your RootsMagic 7 program screen, and click on it.  You will then be able to continue working with FamilySearch Family Tree as if nothing has changed.

If you are running RootsMagic 6….To continue working with FamilySearch through RootsMagic, you have 2 options:

  1. Order the upgrade to RootsMagic 7 [it’s $19.95] OR
  2. Download the free RootsMagic 7 Essentials and install it (leave your RM6 installed as well). RootsMagic 6 and 7 have the same file format, so you can switch back and forth between them with your same database. You can use all the features in your paid RM6, and use RM7 Essentials when you need to work with FamilySearch Family Tree.

For the full scoop on what’s new with this update, click here. Please share this important post with other RootsMagic users!

Read these articles next for more on RootsMagic:

Best Family History Software (And Why Use It!)

Why I Use RootsMagic Family History Software

Free RootsMagic Magic Guides

Free Support for RootsMagic Users

RootsMagic + MyHeritage = Heritage Magic!

Pin It on Pinterest

Share This
MENU